Which iOS phones does Yulio support?

We recommend using Yulio with iPhone 6/6s devices running the latest version of iOS.

Performance may vary on older devices.

Have more questions? Submit a request